using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/.*\/(?=\bapp\b)";
string input = @"/User/username/Code/project/app/Controllers/MyClass.php
/User/username/Code/company_web_app/app/Controllers/MyClass.php";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}