re = /^\/.*\/(?=\bapp\b)/m
str = '/User/username/Code/project/app/Controllers/MyClass.php
/User/username/Code/company_web_app/app/Controllers/MyClass.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end