using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bInternet\b(?=(?:[^""]*""[^""]*"")*[^""]*$)";
string input = @"Internet ""InternetFormula works and it's internetformula""
Internet ""The internet works""";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}