$re = '/\bInternet\b(?=(?:[^"]*"[^"]*")*[^"]*$)/im';
$str = 'Internet "InternetFormula works and it\'s internetformula"
Internet "The internet works"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);