#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(\/\*(.|\s)*\*\/)"
Local $sString = "This is a test. " & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"" & @CRLF & _
"With comments " & @CRLF & _
"" & @CRLF & _
"on multiple" & @CRLF & _
"" & @CRLF & _
"lines." & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"End of text."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")