$re = '/(\/\*(.|\s)*\*\/)/mx';
$str = 'This is a test.
/*
With comments
on multiple
lines.
*/
End of text.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);