package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)(\/\*(.|\s)*\*\/)`)
var str = `This is a test.
/*
With comments
on multiple
lines.
*/
End of text.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}