package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*=.*[^=]*$`)
var str = `Wert1=Hallo
dsadasd
and a third line
Wert2=Hi
Wert3=Heinirch Volland`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}