re = /^.*=.*[^=]*$/m
str = 'Wert1=Hallo
dsadasd
and a third line
Wert2=Hi
Wert3=Heinirch Volland'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end