$re = '/^.*=.*[^=]*$/m';
$str = 'Wert1=Hallo
dsadasd
and a third line
Wert2=Hi
Wert3=Heinirch Volland';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);