using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"filename=(['""])?(?(1)(.+?)\1|([^;]+))";
string input = @"$str = 'attachment;filename=""unnamed.jpg"";filename*=UTF-8\'\'unnamed.jpg\'';
$str = 'attachment;filename=unnamed.jpg;filename*=unnamed.jpg';";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}