re = /filename=(['"])?(?(1)(.+?)\1|([^;]+))/
str = '$str = \'attachment;filename="unnamed.jpg";filename*=UTF-8\\\'\\\'unnamed.jpg\\\'\';
$str = \'attachment;filename=unnamed.jpg;filename*=unnamed.jpg\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end