$re = '~filename=([\'"])?(?(1)(.+?)\1|([^;]+))~';
$str = '$str = \'attachment;filename="unnamed.jpg";filename*=UTF-8\\\'\\\'unnamed.jpg\\\'\';
$str = \'attachment;filename=unnamed.jpg;filename*=unnamed.jpg\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);