using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=: )[^[]+\[ME\]|^[^[]+\[ME\](?= :)";
string input = @"Seat 7: Bug One [ME] (82 power)
Bug One [ME] : xx xxxxx xxxxxx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}