$re = '/(?<=: )[^[]+\[ME\]|^[^[]+\[ME\](?= :)/m';
$str = 'Seat 7: Bug One [ME] (82 power)
Bug One [ME] : xx xxxxx xxxxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);