import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=: )[^[]+\\[ME\\]|^[^[]+\\[ME\\](?= :)";
final String string = "Seat 7: Bug One [ME] (82 power)\n"
+ "Bug One [ME] : xx xxxxx xxxxxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}