# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<Interceptor>(.*)\<ActionDate\>2-04-24\<\\/ActionDate\>(.*)\<RecordNotes\>test\<\\/RecordNotes\>(.*)\<\\/Interceptor\>/<Interceptor\>\<ActionDate\>2-04-24\<\\/ActionDate\>\<RecordNotes\>test\<\\/RecordNotes\>\<\\/Interceptor\>/g;t' <<< "<Interceptor> <AttackCoords>-423423445345345.10742916222947</AttackCoords> <Outcome>2</Outcome> <Infiltrators>20</Infiltrators> <Enforcer>2</Enforcer> <ActionDate>2-04-24</ActionDate> <ActionTime>00:2:00</ActionTime> <RecordNotes>test</RecordNotes> <NumEscaped>0</NumEscaped> <LaunchCoords>-222222</LaunchCoords> <AttackVessel>111</AttackVessel> </Interceptor>"