re = /<Interceptor>(.*)\<ActionDate\>2-04-24\<\/ActionDate\>(.*)\<RecordNotes\>test\<\/RecordNotes\>(.*)\<\/Interceptor\>/
str = '<Interceptor> <AttackCoords>-423423445345345.10742916222947</AttackCoords> <Outcome>2</Outcome> <Infiltrators>20</Infiltrators> <Enforcer>2</Enforcer> <ActionDate>2-04-24</ActionDate> <ActionTime>00:2:00</ActionTime> <RecordNotes>test</RecordNotes> <NumEscaped>0</NumEscaped> <LaunchCoords>-222222</LaunchCoords> <AttackVessel>111</AttackVessel> </Interceptor>'
subst = '<Interceptor\\>\\<ActionDate\\>2-04-24\\<\\/ActionDate\\>\\<RecordNotes\\>test\\<\\/RecordNotes\\>\\<\\/Interceptor\\>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result