// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<Interceptor>(.*)\<ActionDate\>2-04-24\<\/ActionDate\>(.*)\<RecordNotes\>test\<\/RecordNotes\>(.*)\<\/Interceptor\>").unwrap();
let string = "<Interceptor> <AttackCoords>-423423445345345.10742916222947</AttackCoords> <Outcome>2</Outcome> <Infiltrators>20</Infiltrators> <Enforcer>2</Enforcer> <ActionDate>2-04-24</ActionDate> <ActionTime>00:2:00</ActionTime> <RecordNotes>test</RecordNotes> <NumEscaped>0</NumEscaped> <LaunchCoords>-222222</LaunchCoords> <AttackVessel>111</AttackVessel> </Interceptor>";
let substitution = "<Interceptor\\>\\<ActionDate\\>2-04-24\\<\\/ActionDate\\>\\<RecordNotes\\>test\\<\\/RecordNotes\\>\\<\\/Interceptor\\>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}