using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9_.'])+@(([a-zA-Z0-9-])+.)+([a-zA-Z0-9]{2,4})+$";
string input = @"aodisjfoij@fvghbj456789_f.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}