$re = '/^([a-zA-Z0-9_.\'])+@(([a-zA-Z0-9-])+.)+([a-zA-Z0-9]{2,4})+$/';
$str = 'aodisjfoij@fvghbj456789_f.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);