const regex = /^([a-zA-Z0-9_.'])+@(([a-zA-Z0-9-])+.)+([a-zA-Z0-9]{2,4})+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9_.\'])+@(([a-zA-Z0-9-])+.)+([a-zA-Z0-9]{2,4})+$', '')
const str = `aodisjfoij@fvghbj456789_f.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}