using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*[\S\s]*?\*\/)|(\/\/[^\n]*)";
string input = @"{
filed: { // comments
n: 1 /* multi-line ...
comments */
},
field2: "" // comments in string , /* here */ ""
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}