$re = '/(\/\*[\S\s]*?\*\/)|(\/\/[^\n]*)/m';
$str = '{
filed: { // comments
n: 1 /* multi-line ...
comments */
},
field2: " // comments in string , /* here */ "
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);