import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\*[\\S\\s]*?\\*\\/)|(\\/\\/[^\\n]*)";
final String string = "{\n"
+ " filed: { // comments\n"
+ " n: 1 /* multi-line ...\n"
+ " comments */\n"
+ " },\n"
+ " field2: \" // comments in string , /* here */ \"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}