package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{1,9})?$`)
var str = `120000.343123
120000.2
12,000,000,000.122212121`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}