re = /^[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{1,9})?$/mi
str = '120000.343123
120000.2
12,000,000,000.122212121'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end