$re = '/^[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{1,9})?$/mi';
$str = '120000.343123
120000.2
12,000,000,000.122212121';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);