using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
(?!
[^a-zA-Z0-9'-]+
| (?<! [a-zA-Z0-9] )
'
| '
(?! [a-zA-Z0-9] )
)
.
)+
";
string input = @"didn't Shannons' consecrated—we, l'k'";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}