// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?:
(?!
[^a-zA-Z0-9'-]+
| (?<! [a-zA-Z0-9] )
'
| '
(?! [a-zA-Z0-9] )
)
.
)+
").unwrap();
let string = "didn't Shannons' consecrated—we, l'k'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}