re = /(?:
(?!
[^a-zA-Z0-9'-]+
| (?<! [a-zA-Z0-9] )
'
| '
(?! [a-zA-Z0-9] )
)
.
)+
/x
str = 'didn\'t Shannons\' consecrated—we, l\'k\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end