#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/.+"
Local $sString = "https://ok.ru/videoembed/9764262647149/1745154591502/583149145965/jibj52SnD6JC2IlcuvRS6Ji_k5U/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1" & @CRLF & _
"Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)" & @CRLF & _
"Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36" & @CRLF & _
"Config: one-video-config, ui, core" & @CRLF & _
"United video id: 9764262712685" & @CRLF & _
"Content host: vd339.okcdn.ru" & @CRLF & _
"Connection type: http1 (reused)" & @CRLF & _
"Throughput: 18589Kbps @ 69ms RTT" & @CRLF & _
"Format: DASH_ONDEMAND" & @CRLF & _
"Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG" & @CRLF & _
"Streams: Video: avc1, Audio: mp4a" & @CRLF & _
"Quality: auto 240p" & @CRLF & _
"Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p" & @CRLF & _
"Position: 30.869158s" & @CRLF & _
"State: video playing" & @CRLF & _
"Player size: 374x210" & @CRLF & _
"URL: https://ok.ru/videoembed/9764262712685/1745154591508/583149145965/6iPEv_U378vsO3QzTiO30hX1zpo/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1" & @CRLF & _
"Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)" & @CRLF & _
"Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36" & @CRLF & _
"Config: one-video-config, ui, core" & @CRLF & _
"United video id: 9764262778221" & @CRLF & _
"Content host: vd371.okcdn.ru" & @CRLF & _
"Connection type: http1 (reused)" & @CRLF & _
"Throughput: 23293Kbps @ 69ms RTT" & @CRLF & _
"Format: DASH_ONDEMAND" & @CRLF & _
"Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG" & @CRLF & _
"Streams: Video: avc1, Audio: mp4a" & @CRLF & _
"Quality: auto 240p" & @CRLF & _
"Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p" & @CRLF & _
"Position: 31.865475s" & @CRLF & _
"State: video paused" & @CRLF & _
"Player size: 374x210" & @CRLF & _
"URL: https://ok.ru/videoembed/9764262778221/1745154591513/583149145965/yvlfBg9CQxEu_rxEHULd-WmknXU/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1" & @CRLF & _
"Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)" & @CRLF & _
"Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36" & @CRLF & _
"Config: one-video-config, ui, core" & @CRLF & _
"United video id: 9764268152173" & @CRLF & _
"Content host: vd172.okcdn.ru" & @CRLF & _
"Connection type: http1 (reused)" & @CRLF & _
"Throughput: 23765Kbps @ 64ms RTT" & @CRLF & _
"Format: DASH_ONDEMAND" & @CRLF & _
"Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG" & @CRLF & _
"Streams: Video: avc1, Audio: mp4a" & @CRLF & _
"Quality: auto 240p" & @CRLF & _
"Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p" & @CRLF & _
"Position: 33.377752s" & @CRLF & _
"State: video paused" & @CRLF & _
"Player size: 374x210" & @CRLF & _
"URL: https://ok.ru/videoembed/9764268152173/1745154591518/583149145965/uFTos2QLp_Xct3fXaSUyx-tVFqs/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1" & @CRLF & _
"Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)" & @CRLF & _
"Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36" & @CRLF & _
"Config: one-video-config, ui, core" & @CRLF & _
"United video id: 9764268676461" & @CRLF & _
"Content host: vd442.okcdn.ru" & @CRLF & _
"Connection type: http1 (reused)" & @CRLF & _
"Throughput: 12644Kbps @ 69ms RTT" & @CRLF & _
"Format: DASH_ONDEMAND" & @CRLF & _
"Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG" & @CRLF & _
"Streams: Video: avc1, Audio: mp4a" & @CRLF & _
"Quality: auto 240p" & @CRLF & _
"Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p" & @CRLF & _
"Position: 35.628398s" & @CRLF & _
"State: video paused" & @CRLF & _
"Player size: 374x210" & @CRLF & _
"URL: https://ok.ru/videoembed/9764268676461/1745154591525/583149145965/0HkRt5VtPLHylokS3SXWJa3qias/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1" & @CRLF & _
"Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)" & @CRLF & _
"Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36" & @CRLF & _
"Config: one-video-config, ui, core" & @CRLF & _
"United video id: 9764269921645" & @CRLF & _
"Content host: vd510.okcdn.ru" & @CRLF & _
"Connection type: http1 (reused)" & @CRLF & _
"Throughput: 13317Kbps @ 71ms RTT" & @CRLF & _
"Format: DASH_ONDEMAND" & @CRLF & _
"Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG" & @CRLF & _
"Streams: Video: avc1, Audio: mp4a" & @CRLF & _
"Quality: auto 240p" & @CRLF & _
"Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p" & @CRLF & _
"Position: 37.933283s" & @CRLF & _
"State: video paused" & @CRLF & _
"Player size: 374x210" & @CRLF & _
"URL: https://ok.ru/videoembed/9764269921645/1745154591531/583149145965/olfC3KI6LA6lXekGtwm-n8kz93U/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1" & @CRLF & _
"Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)" & @CRLF & _
"Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36" & @CRLF & _
"Config: one-video-config, ui, core" & @CRLF & _
"United video id: 9764274443629" & @CRLF & _
"Content host: vd393.okcdn.ru" & @CRLF & _
"Connection type: http1 (reused)" & @CRLF & _
"Throughput: 14329Kbps @ 66ms RTT" & @CRLF & _
"Format: DASH_ONDEMAND" & @CRLF & _
"Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG" & @CRLF & _
"Streams: Video: avc1, Audio: mp4a" & @CRLF & _
"Quality: auto 240p" & @CRLF & _
"Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p" & @CRLF & _
"Position: 39.730862s" & @CRLF & _
"State: video paused" & @CRLF & _
"Player size: 374x210" & @CRLF & _
"URL: https://ok.ru/videoembed/9764274443629/1745154591536/583149145965/5_3iPoz9q0VNeXxwg2nttQEeMLs/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1" & @CRLF & _
"Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)" & @CRLF & _
"Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36" & @CRLF & _
"https://ok.ru/videoembed/9764275230061/1745154591545/583149145965/Ts7HAJSO1FyvKLGEvDvLYsX-RFw/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")