import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/.+";
final String string = "https://ok.ru/videoembed/9764262647149/1745154591502/583149145965/jibj52SnD6JC2IlcuvRS6Ji_k5U/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1\n"
+ "Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)\n"
+ "Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36\n"
+ "Config: one-video-config, ui, core\n"
+ "United video id: 9764262712685\n"
+ "Content host: vd339.okcdn.ru\n"
+ "Connection type: http1 (reused)\n"
+ "Throughput: 18589Kbps @ 69ms RTT\n"
+ "Format: DASH_ONDEMAND\n"
+ "Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG\n"
+ "Streams: Video: avc1, Audio: mp4a\n"
+ "Quality: auto 240p\n"
+ "Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p\n"
+ "Position: 30.869158s\n"
+ "State: video playing\n"
+ "Player size: 374x210\n"
+ "URL: https://ok.ru/videoembed/9764262712685/1745154591508/583149145965/6iPEv_U378vsO3QzTiO30hX1zpo/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1\n"
+ "Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)\n"
+ "Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36\n"
+ "Config: one-video-config, ui, core\n"
+ "United video id: 9764262778221\n"
+ "Content host: vd371.okcdn.ru\n"
+ "Connection type: http1 (reused)\n"
+ "Throughput: 23293Kbps @ 69ms RTT\n"
+ "Format: DASH_ONDEMAND\n"
+ "Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG\n"
+ "Streams: Video: avc1, Audio: mp4a\n"
+ "Quality: auto 240p\n"
+ "Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p\n"
+ "Position: 31.865475s\n"
+ "State: video paused\n"
+ "Player size: 374x210\n"
+ "URL: https://ok.ru/videoembed/9764262778221/1745154591513/583149145965/yvlfBg9CQxEu_rxEHULd-WmknXU/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1\n"
+ "Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)\n"
+ "Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36\n"
+ "Config: one-video-config, ui, core\n"
+ "United video id: 9764268152173\n"
+ "Content host: vd172.okcdn.ru\n"
+ "Connection type: http1 (reused)\n"
+ "Throughput: 23765Kbps @ 64ms RTT\n"
+ "Format: DASH_ONDEMAND\n"
+ "Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG\n"
+ "Streams: Video: avc1, Audio: mp4a\n"
+ "Quality: auto 240p\n"
+ "Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p\n"
+ "Position: 33.377752s\n"
+ "State: video paused\n"
+ "Player size: 374x210\n"
+ "URL: https://ok.ru/videoembed/9764268152173/1745154591518/583149145965/uFTos2QLp_Xct3fXaSUyx-tVFqs/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1\n"
+ "Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)\n"
+ "Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36\n"
+ "Config: one-video-config, ui, core\n"
+ "United video id: 9764268676461\n"
+ "Content host: vd442.okcdn.ru\n"
+ "Connection type: http1 (reused)\n"
+ "Throughput: 12644Kbps @ 69ms RTT\n"
+ "Format: DASH_ONDEMAND\n"
+ "Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG\n"
+ "Streams: Video: avc1, Audio: mp4a\n"
+ "Quality: auto 240p\n"
+ "Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p\n"
+ "Position: 35.628398s\n"
+ "State: video paused\n"
+ "Player size: 374x210\n"
+ "URL: https://ok.ru/videoembed/9764268676461/1745154591525/583149145965/0HkRt5VtPLHylokS3SXWJa3qias/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1\n"
+ "Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)\n"
+ "Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36\n"
+ "Config: one-video-config, ui, core\n"
+ "United video id: 9764269921645\n"
+ "Content host: vd510.okcdn.ru\n"
+ "Connection type: http1 (reused)\n"
+ "Throughput: 13317Kbps @ 71ms RTT\n"
+ "Format: DASH_ONDEMAND\n"
+ "Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG\n"
+ "Streams: Video: avc1, Audio: mp4a\n"
+ "Quality: auto 240p\n"
+ "Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p\n"
+ "Position: 37.933283s\n"
+ "State: video paused\n"
+ "Player size: 374x210\n"
+ "URL: https://ok.ru/videoembed/9764269921645/1745154591531/583149145965/olfC3KI6LA6lXekGtwm-n8kz93U/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1\n"
+ "Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)\n"
+ "Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36\n"
+ "Config: one-video-config, ui, core\n"
+ "United video id: 9764274443629\n"
+ "Content host: vd393.okcdn.ru\n"
+ "Connection type: http1 (reused)\n"
+ "Throughput: 14329Kbps @ 66ms RTT\n"
+ "Format: DASH_ONDEMAND\n"
+ "Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG\n"
+ "Streams: Video: avc1, Audio: mp4a\n"
+ "Quality: auto 240p\n"
+ "Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p\n"
+ "Position: 39.730862s\n"
+ "State: video paused\n"
+ "Player size: 374x210\n"
+ "URL: https://ok.ru/videoembed/9764274443629/1745154591536/583149145965/5_3iPoz9q0VNeXxwg2nttQEeMLs/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1\n"
+ "Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)\n"
+ "Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36\n"
+ "https://ok.ru/videoembed/9764275230061/1745154591545/583149145965/Ts7HAJSO1FyvKLGEvDvLYsX-RFw/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}