using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/.+";
string input = @"https://ok.ru/videoembed/9764262647149/1745154591502/583149145965/jibj52SnD6JC2IlcuvRS6Ji_k5U/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1
Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36
Config: one-video-config, ui, core
United video id: 9764262712685
Content host: vd339.okcdn.ru
Connection type: http1 (reused)
Throughput: 18589Kbps @ 69ms RTT
Format: DASH_ONDEMAND
Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG
Streams: Video: avc1, Audio: mp4a
Quality: auto 240p
Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p
Position: 30.869158s
State: video playing
Player size: 374x210
URL: https://ok.ru/videoembed/9764262712685/1745154591508/583149145965/6iPEv_U378vsO3QzTiO30hX1zpo/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1
Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36
Config: one-video-config, ui, core
United video id: 9764262778221
Content host: vd371.okcdn.ru
Connection type: http1 (reused)
Throughput: 23293Kbps @ 69ms RTT
Format: DASH_ONDEMAND
Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG
Streams: Video: avc1, Audio: mp4a
Quality: auto 240p
Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p
Position: 31.865475s
State: video paused
Player size: 374x210
URL: https://ok.ru/videoembed/9764262778221/1745154591513/583149145965/yvlfBg9CQxEu_rxEHULd-WmknXU/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1
Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36
Config: one-video-config, ui, core
United video id: 9764268152173
Content host: vd172.okcdn.ru
Connection type: http1 (reused)
Throughput: 23765Kbps @ 64ms RTT
Format: DASH_ONDEMAND
Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG
Streams: Video: avc1, Audio: mp4a
Quality: auto 240p
Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p
Position: 33.377752s
State: video paused
Player size: 374x210
URL: https://ok.ru/videoembed/9764268152173/1745154591518/583149145965/uFTos2QLp_Xct3fXaSUyx-tVFqs/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1
Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36
Config: one-video-config, ui, core
United video id: 9764268676461
Content host: vd442.okcdn.ru
Connection type: http1 (reused)
Throughput: 12644Kbps @ 69ms RTT
Format: DASH_ONDEMAND
Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG
Streams: Video: avc1, Audio: mp4a
Quality: auto 240p
Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p
Position: 35.628398s
State: video paused
Player size: 374x210
URL: https://ok.ru/videoembed/9764268676461/1745154591525/583149145965/0HkRt5VtPLHylokS3SXWJa3qias/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1
Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36
Config: one-video-config, ui, core
United video id: 9764269921645
Content host: vd510.okcdn.ru
Connection type: http1 (reused)
Throughput: 13317Kbps @ 71ms RTT
Format: DASH_ONDEMAND
Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG
Streams: Video: avc1, Audio: mp4a
Quality: auto 240p
Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p
Position: 37.933283s
State: video paused
Player size: 374x210
URL: https://ok.ru/videoembed/9764269921645/1745154591531/583149145965/olfC3KI6LA6lXekGtwm-n8kz93U/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1
Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36
Config: one-video-config, ui, core
United video id: 9764274443629
Content host: vd393.okcdn.ru
Connection type: http1 (reused)
Throughput: 14329Kbps @ 66ms RTT
Format: DASH_ONDEMAND
Available Formats: DASH_ONDEMAND, HLS_ONDEMAND, MPEG
Streams: Video: avc1, Audio: mp4a
Quality: auto 240p
Available qualities: 1080p, 720p, 480p, 360p, 240p, 144p
Position: 39.730862s
State: video paused
Player size: 374x210
URL: https://ok.ru/videoembed/9764274443629/1745154591536/583149145965/5_3iPoz9q0VNeXxwg2nttQEeMLs/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1
Version: 1.1.57 (core: 2.0.127, stat: 1.0.72, shared: 1.0.55)
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Atom/26.0.0.0 Safari/537.36
https://ok.ru/videoembed/9764275230061/1745154591545/583149145965/Ts7HAJSO1FyvKLGEvDvLYsX-RFw/00000087C665CF6D0000008A2E70EB0F0A00000196531ADA1A11B60000000000000000?autoplay=1&white=1&muted=1&silent=1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}