import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*(?:(?:(\\/)([^\\/]*)[\\/]|(_)([^,=]+)|()([^,=]+))(?(?==)\\=([^,]+)))\\s*,?)+?";
final String string = "/test[2],[e] tes/, /eq we/=$2, dghg,hui hghgh=daa,_9XXXX";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}