$re = '/(?:\s*(?:(?:(\/)([^\/]*)[\/]|(_)([^,=]+)|()([^,=]+))(?(?==)\=([^,]+)))\s*,?)+?/';
$str = '/test[2],[e] tes/, /eq we/=$2, dghg,hui hghgh=daa,_9XXXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);