re = /(?:\s*(?:(?:(\/)([^\/]*)[\/]|(_)([^,=]+)|()([^,=]+))(?(?==)\=([^,]+)))\s*,?)+?/
str = '/test[2],[e] tes/, /eq we/=$2, dghg,hui hghgh=daa,_9XXXX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end