package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{2}-(?:\d{4}-){3}\d{1}`)
var str = `12-1234-5678-0000-1
12-1234-5678-0000-12`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}