$re = '/\d{2}-(?:\d{4}-){3}\d{1}/';
$str = '12-1234-5678-0000-1
12-1234-5678-0000-12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);