const regex = /\d{2}-(?:\d{4}-){3}\d{1}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}-(?:\\d{4}-){3}\\d{1}', '')
const str = `12-1234-5678-0000-1
12-1234-5678-0000-12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}