import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\S ]+)(\\n*)([\\s\\S]*?)Bar([\\s\\S]*?)Baz([\\s\\S]*?)";
final String string = "Foo 1\n"
+ "foo1Text\n\n"
+ "Bar\n"
+ "bar1Text\n\n"
+ "Baz\n"
+ "baz1Text\n"
+ " \n"
+ "Foo 2\n"
+ "foo2Text\n\n"
+ "Bar\n"
+ "bar2Text\n\n"
+ "Baz\n"
+ "baz2Text\n\n"
+ "# and so on up to Foo/Bar/Baz N";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}