package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\\]+\.[^.]+$`)
var str = `Stuff - Old Channels 💀 - image-assets [839605635295772672].csv_Files\IMG_0165-E23DF.JPG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}