$re = '/[^\\\\]+\.[^.]+$/m';
$str = 'Stuff - Old Channels 💀 - image-assets [839605635295772672].csv_Files\\IMG_0165-E23DF.JPG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);