re = /[^\\]+\.[^.]+$/m
str = 'Stuff - Old Channels 💀 - image-assets [839605635295772672].csv_Files\\IMG_0165-E23DF.JPG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end