using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^test:.*$";
string input = @"Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
test: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}