// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^test:.*$").unwrap();
let string = "Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
test: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189
Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}