import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^test:.*$";
final String string = "Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189\n"
+ "test: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189\n"
+ "Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189\n"
+ "Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}