const regex = new RegExp('(?!^)\\'(\\d+)\\s+(\\w+)\\s+(\\w+)\\s+([^\\']*?)\\s+(\\S+)\\s+(\\S+)\\s+([\\d.]+)\\s+(\\d+)\\s+([\\d.]+)\\'', 'gm')
const str = `'PoE Port Info','1 up medium Auto Class Searching 0 0.0 0 0.0','10 up low User defined 4(W) Searching - 0.0 0 0.0'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}