re = /(?!^)'(\d+)\s+(\w+)\s+(\w+)\s+([^']*?)\s+(\S+)\s+(\S+)\s+([\d.]+)\s+(\d+)\s+([\d.]+)'/m
str = '\'PoE Port Info\',\'1 up medium Auto Class Searching 0 0.0 0 0.0\',\'10 up low User defined 4(W) Searching - 0.0 0 0.0\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end