const regex = new RegExp('(?<!\\S)pattern(?!\\S)(?=(?:(?!(?<!\\S)(?:start|end)(?!\\S)).)*?(?<!\\S)end(?!\\S))', 'gm')
const str = `pattern foo start fkdsjflsd pattern jdflsdjf pattern end`;
const subst = `replace_pattern`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);